Sharing & diskusi mahasiswa TI UMMgl.
 
IndeksCalendarFAQPencarianAnggotaGroupPendaftaranLogin

Share | 
 

 Load balancing 2 ISP + Management Bandwidth

Topik sebelumnya Topik selanjutnya Go down 
PengirimMessage
Admin
Admin


Jumlah posting : 27
Join date : 02.06.10
Lokasi : Magelang

PostSubyek: Load balancing 2 ISP + Management Bandwidth   Wed Feb 16, 2011 12:58 am

Load balancing = menggabungkan beberapa koneksi ISP untuk suatu jaringan LAN
router = RB 750 v 4.10



teruji dengan 17 komputer klien. alien

script dibuat berdasarkan dari forummikrotik.com <----- study

maaf kemasannya gak menarik ....... scratch






1. Pake WinBox masuk ke -> IP -> Address
-> klik [+] -> isikan Address : 192.168.2.1/30 _
Network : 192.168.2.0 |
Broadcast : 192.168.2.3 | Konfigurasi WAN 1
Interface : ether1 _|
-> klik [+] -> isikan Address : 192.168.1.1/30 _
Network : 192.168.1.0 |
Broadcast : 192.168.1.3 | Konfigurasi WAN 2
Interface : ether2 _|
-> klik [+] -> isikan Address : 192.168.3.1/27 _
Network : 192.168.3.0 |
Broadcast : 192.168.3.31 | Konfigurasi WAN 2
Interface : ether4 _|

2. Buat Mangle. Pake WinBox pilih -> New Terminal
Paste kan Kode Berikut
/ip firewall mangle [lalu enter]
add chain=prerouting in-interface="ether4" connection-state=new nth=2,1 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
add chain=prerouting in-interface="ether4" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
add chain=prerouting in-interface="ether4" connection-state=new nth=2,2 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
add chain=prerouting in-interface="ether4" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no
[lalu enter]


3. Buat Nat. Pake WinBox pilih -> New Terminal
Lagi Lagi Paste kan [ maklum sebagai newbie males nulis ]
/ ip firewall nat
add chain=srcnat out-interface="ether1" action=masquerade comment="" disabled=no
add chain=srcnat out-interface="ether2" action=masquerade comment="" disabled=no

4. Buat Route. Pake WinBox pilih -> New Terminal
Copy Paste Lagi Bosssss
/ ip route
add dst-address=0.0.0.0/0 distance=1 gateway=192.168.1.2 scope=30 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
add dst-address=0.0.0.0/0 distance=1 gateway=192.168.2.2 scope=30 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
add dst-address=0.0.0.0/0 distance=1 gateway=192.168.1.2, 192.168.2.2 scope=30 target-scope=10 comment="Routing terakhir jika gagal" disabled=no
Sampai Disini Load Balancing Telah Beres...

::: Tambahan :::
Bagi yang merasa kesulitan atau eror saat akses Internet Banking menggunakan Load Balance bisa menambahkan rule berikut ini, dan kalau posisi-nya Akang rule ini ditaruh di bawah rule Load Balance
/ip firewall mangle add action=mark-connection chain=prerouting comment="menandai koneksi HTTPS" \
connection-state=new disabled=no dst-port=443 in-interface=ether4 \
new-connection-mark=koneksi_HTTPS passthrough=yes protocol=tcp src-address=\
192.168.3.0/27
add action=mark-routing chain=prerouting comment="melakukan aksi terhadap koneksi HTTPS" connection-mark=\
koneksi_HTTPS disabled=no in-interface=ether4 new-routing-mark=https-route \
passthrough=no
/ip route add gateway=192.168.2.2 routing-mark=https-route



-----------------------------------------------marking koneksi 17 PC
/ip firewall mangle add chain=prerouting src-address=192.168.3.17 action=mark-connection new-connection-mark=koneksi-klien1 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.2 action=mark-connection new-connection-mark=koneksi-klien2 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.3 action=mark-connection new-connection-mark=koneksi-klien3 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.4 action=mark-connection new-connection-mark=koneksi-klien4 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.5 action=mark-connection new-connection-mark=koneksi-klien5 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.6 action=mark-connection new-connection-mark=koneksi-klien6 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.7 action=mark-connection new-connection-mark=koneksi-klien7 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.8 action=mark-connection new-connection-mark=koneksi-klien8 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.9 action=mark-connection new-connection-mark=koneksi-klien9 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.10 action=mark-connection new-connection-mark=koneksi-klien10 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.11 action=mark-connection new-connection-mark=koneksi-klien11 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.12 action=mark-connection new-connection-mark=koneksi-klien12 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.13 action=mark-connection new-connection-mark=koneksi-klien13 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.14 action=mark-connection new-connection-mark=koneksi-klien14 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.15 action=mark-connection new-connection-mark=koneksi-klien15 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.16 action=mark-connection new-connection-mark=koneksi-klien16 passthrough=yes
/ip firewall mangle add chain=prerouting src-address=192.168.3.30 action=mark-connection new-connection-mark=koneksi-billing-server passthrough=yes


-----------------------------------------------marking paket 17 PC
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien1 action=mark-packet new-packet-mark=paket-klien1 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien2 action=mark-packet new-packet-mark=paket-klien2 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien3 action=mark-packet new-packet-mark=paket-klien3 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien4 action=mark-packet new-packet-mark=paket-klien4 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien5 action=mark-packet new-packet-mark=paket-klien5 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien6 action=mark-packet new-packet-mark=paket-klien6 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien7 action=mark-packet new-packet-mark=paket-klien7 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien8 action=mark-packet new-packet-mark=paket-klien8 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien9 action=mark-packet new-packet-mark=paket-klien9 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien10 action=mark-packet new-packet-mark=paket-klien10 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien11 action=mark-packet new-packet-mark=paket-klien11 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien12 action=mark-packet new-packet-mark=paket-klien12 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien13 action=mark-packet new-packet-mark=paket-klien13 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien14 action=mark-packet new-packet-mark=paket-klien14 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien15 action=mark-packet new-packet-mark=paket-klien15 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-klien16 action=mark-packet new-packet-mark=paket-klien16 passthrough=yes
/ip firewall mangle add chain=prerouting connection-mark=koneksi-billing-server action=mark-packet new-packet-mark=paket-billing-server passthrough=yes


-----------------------------------------------parrent kecepatan download
/queue tree add name=parrent-download parent=ether4 max-limit=2080 priority=6

setelah itu edit menggunakan winbox untuk mengganti angka max-limit menjadi max-limit=2080k


-----------------------------------------------Queue tree kecepatan download berdasarkan klien
/queue tree add name=klien1-download parent=parrent-download packet-mark=paket-klien1 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien2-download parent=parrent-download packet-mark=paket-klien2 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien3-download parent=parrent-download packet-mark=paket-klien3 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien4-download parent=parrent-download packet-mark=paket-klien4 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien5-download parent=parrent-download packet-mark=paket-klien5 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien6-download parent=parrent-download packet-mark=paket-klien6 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien7-download parent=parrent-download packet-mark=paket-klien7 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien8-download parent=parrent-download packet-mark=paket-klien8 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien9-download parent=parrent-download packet-mark=paket-klien9 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien10-download parent=parrent-download packet-mark=paket-klien10 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien11-download parent=parrent-download packet-mark=paket-klien11 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien12-download parent=parrent-download packet-mark=paket-klien12 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien13-download parent=parrent-download packet-mark=paket-klien13 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien14-download parent=parrent-download packet-mark=paket-klien14 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien15-download parent=parrent-download packet-mark=paket-klien15 limit-at=90 max-limit=2080 priority=8
/queue tree add name=klien16-download parent=parrent-download packet-mark=paket-klien16 limit-at=90 max-limit=2080 priority=8
/queue tree add name=billing-server-download parent=parrent-download packet-mark=paket-billing-server limit-at=90 max-limit=2080 priority=8


setelah itu cek menggunakan winbox apakah limit-at=90 = limit-at=90k, dan , max-limit=2080k sama dengan max-limit=2080k kalau tidak ganti secara manual


spesial thanks to : Pak Bambang, orchid@net What a Face

Kembali Ke Atas Go down
Lihat profil user http://tiumm.forumpro.org
 
Load balancing 2 ISP + Management Bandwidth
Topik sebelumnya Topik selanjutnya Kembali Ke Atas 
Halaman 1 dari 1
 Similar topics
-
» Motorcycle Safety - Crash Reminder & Risk Management

Permissions in this forum:Anda tidak dapat menjawab topik
Teknik Informatika UM Magelang :: Jaringan-
Navigasi: